Recommended Browsers

Firefox
Firefox 3.6+
(for PC or Mac)
Chrome
Chrome 4.0+
(for PC or Mac)

Compatible Browsers
These will work in most instances when viewing courses, but may have some compatibility issues when building courses:
(Note: Any version of Internet Explorer is not recommended.)

More Moodle Support Information

    Skip site news

    Site news

    (No news has been posted yet)